500 Internal Server Error

cleiner

Onaylı Üye
Katılım
11 Nis 2010
Mesajlar
290
Beğeniler
5
Yaş
31
#21
panelden httpdocs içine gireceksin klasörlerin dışındaki dosyaların en üstünde yer alır zaten.
scrptin içerisinde öyle bir dosya yok malesef :s scrptin yayımlaycısı 500 hatasının yazma izinleriyle alakalı olduğunu yazıyor bütün dosyalara yazma izni verdim yinede aynı hata ile karşıkarşıya kaldım.
 
T
#22
Aklıma gelen en mantıklı şey o scripti kuallanan birisine ulaşıp .htaccess dosyasını istemek.
 

OnuR

Müptela
Katılım
28 Eki 2004
Mesajlar
1,817
Beğeniler
52
Yaş
29
Konum
makedonya
#23
Eğer error_log dosyası varsa public_html içinde onu silin.
Serverınız Litespeed ise bazen chmod 777 verince hata verebiliyor onu 755 yapın. Yani yazma izni vermeyin izinleri 755 olarak ayarlayın. ( ilk olarak index.php ye uygulayın.)

Muhtemelen 2. olaydır. Sonucu bildirirseniz yardımcı olabiliriz..
 

CrAzYvZ

Şen Üye
Katılım
25 May 2008
Mesajlar
80
Beğeniler
0
#24
hocam ben smf'de bu hatayı aldım acayip de sinirlendiriyo insanıbu hata. Baya bi uğraştım sonra ftp programından anadizindeki .htaccess dosyasını sildim sorun çözüldü.
 

by_carizma

Profesyonel
Katılım
12 May 2011
Mesajlar
102
Beğeniler
0
Yaş
33
#25
arkadaşlar konuyu hortlatayım. Bende 1.mesajdaki gibi mysqldumper ile yedek almaya çalıştığımda aynı hata alıyorum ve yedekleme başlamıyor. Sunucuyu değiştirdikten sonra oldu bu sunucu ayarlarıyla alakalı ama ne olduğunu bilmiyorum dostlar ?


The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@siteadresi.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Bazı ayarlar şöyle :

Sunucu Tipi Linux / centos 5 / cpanel
Web Sunucusu cgi-fcgi
PHP 5.2.17
PHP Max Mesaj Boyutu 32.00 MB (Megabyte)
PHP En Fazla Yükleme Boyutu 32.00 MB (Megabyte)
PHP Bellek Hafıza limiti 512.00 MB (Megabyte)
MySQL Sürümü 5.1.56
MySQL Paket Boyutu 512.00 MB (Megabyte)

Ekleme: Sorunu çözdüm :

WHM’de Apache PHP SuExec ayarı fcgi olarak seçiliydi bende cgi olarak değiştirip apache restart atıp denedim düzeldi. Lakin vb 4 +seo lu forumda bu ayar hangisinde durmalı ? fcgi mı yoksa cgi mı ? Sunucu optimizasyon yaptırdığımda böyle idi ayarı ?

Ekleme: g ü n c e l d i r
 
Katılım
21 Eyl 2010
Mesajlar
600
Beğeniler
4
Yaş
34
Konum
izmir
#26
bu hata kısaca ftp de .htaccess

silin bunu ekleyin

Kod:
# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hek in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forums/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]
başıma gelmişti olmulu denenmiştir
 

by_carizma

Profesyonel
Katılım
12 May 2011
Mesajlar
102
Beğeniler
0
Yaş
33
#28
WHM’de Apache PHP SuExec ayarı fcgi olarak seçiliydi bende cgi olarak değiştirip apache restart atıp denedim düzeldi. Lakin vb 4 +seo lu forumda bu ayar hangisinde durmalı ? fcgi mı yoksa cgi mı ? Sunucu optimizasyon yaptırdığımda böyle idi ayarı ?
 
Katılım
11 Ağu 2011
Mesajlar
30
Beğeniler
0
Yaş
34
#29
Sizin derleyiciniz suphp olarak seçilmiş olması muhtemeldir.

fastCGI kullanmanızı öneririm.

.htaccess dosyanızın içinde Options -ExecCGI böyle bir komut var ise siliniz, sorununuz düzelecektir.
 

Bu konuyu okuyanlar (Üyeler: 1, Misafirler: 0)

Türkiye’nin ilk webmaster forum sitesi iyinet.com'da forum üyeleri tarafından yapılan tüm paylaşımlardan; Türk Ceza Kanunu’nun 20. Maddesinin, 5651 Sayılı Kanununun 4. maddesinin 2. fıkrasına göre, paylaşım yapan üyeler sorumludur. iyinet.com sayfalarında yer alan yazı, görsel ve linklerle ilgili hukuki şikayetleriniz için Buradan iletişime geçmeniz durumunda, ilgili kanunlar ve yönetmelikler çerçevesinde en geç 7 gün içerisinde iyinet yönetimince tarafınıza dönüş sağlanacaktır.
Üst