wordpress httacces kodları lazım

0
Onaylı Üye
Üye
Katılım
27 Mayıs 2008
Mesajlar
224
Tepki puanı
0
/%category%/%postname%.html

arkadaşlar wordpress te bu şekil yapıyorum kalıcı bağlantıları ancak hosttan kaynaklanan bir sorundan dolayı httacces dosyasını vermiyor otomatik olarak httacces kodlarını bilen bir arkadaş varmı acaba
 
0
Onaylı Üye
Üye
Katılım
23 Eylül 2004
Mesajlar
6,834
Tepki puanı
164
Konum
►∞
/%category%/%post_id%_%postname%.htm


<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /Path/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /path/index.php [L]
</IfModule>
# END WordPress
 
0
Onaylı Üye
Üye
Katılım
27 Mayıs 2008
Mesajlar
224
Tepki puanı
0
/%category%/%postname%.html

bu şekilde olan yokmu birde ıss passwordd diye hata veriyor bu kodlara göre ayarlayınca
 
0
Onaylı Üye
Üye
Katılım
23 Eylül 2004
Mesajlar
6,834
Tepki puanı
164
Konum
►∞
http://www.ziza.net/web/gunce adresinde uygulanmış, çalışıyor.
Sunucun Linux ise (windows sunucularda .htaccess çalışmaz)
Admin, ayarlar, kalıcı bağlantılar bölümünden özel ayarlara /%category%/%postname%.html yaptığında .htaccess kodlarını vermesi gerekil normalde.
Vermiyorsa ftp'den kendin bir .htaccess dosyası oluştur ve chmod 777 yap, tekrar kalıcı bağlantılardan ayarını yap.
 
1
Onaylı Üye
Üye
Katılım
1 Haziran 2008
Mesajlar
2,223
Tepki puanı
12
/%category%/%postname%.html

bu şekilde olan yokmu birde ıss passwordd diye hata veriyor bu kodlara göre ayarlayınca

@bilgi'nin verdiği kod standart.

Sen o dediğin "/%category%/%postname%.html" ayarını kendin ayarlayacaksın, ki ayarlamışsın zaten.

O hatanın nedeni de chmod ayarları olabilir.

.htaccess dosyasını ayarlamasını biliyorsundur umarım.
Ayarladıktan sonra FTP'de bu dosyanın chmod'unu 777 diye ayarla.
Eğer FTP ayarlarında sayı girecek yer yoksa ordaki tüm alanları işaretle.

Anlamadıysan tekrar sorabilirsin.
 
0
Onaylı Üye
Üye
Katılım
27 Mayıs 2008
Mesajlar
224
Tepki puanı
0
http://www.muhurcum.com/ bu siteye yapmaya çalışıyorum ama yapamadım gitti msn adresimi versem yardımcı olacak arkadaş varmı acaba herşeyini yaptım normalde anlarım çok yaptım ama natrodan bu nasılsa heryerde sorun veriyor htaacces koyunca iss hatası veriyor koymayınca düzeliyor
 
1
Onaylı Üye
Üye
Katılım
1 Haziran 2008
Mesajlar
2,223
Tepki puanı
12
Büyük ihtimalle sorun sendedir.

En başa dönelim.

İlk önce şunu sorayım, hostun Linux mu? Eğer cevabın evetse anlatıyorum.

Yeni bir not defteri aç.

İçine yukarıda @bilgi'nin verdiği kodları ekle.

Dosyanın adını .htaccess yap.

Sonra bu dosyayı FTP'de wordpess dosyalarının bulunduğu dizinin içine at.

Sağ tıkla, veya ne bileyim o dosyanın özelliklerini açabileceğin bir şeyler yap.

"chmod" unu 777 yap.
Eğer sayı girecek bir yer yoksa ordaki tüm işaretsizleri işaretle.

Buraya kadar tamam mı?

Sonra gel wordpress admin paneline.

O kalıcı bağlantıların olduğu bölüme o senin ilk mesajındaki kodu yaz, ayarla.

Hallolması lazım.

Eğer hala hallolmuyorsa kesinlikle bir yerde hata yapıyorsun demektir.

Yaptığın her hareketi buraya yazarsan veya ekranın resmini çekersen de olabilir.

Wordpress konusunda uzman değilim ama 2 yıldır ben aynı şekilde ayarlıyorum.
 
0
Onaylı Üye
Üye
Katılım
7 Temmuz 2009
Mesajlar
4
Tepki puanı
0
Konum
Antalya
Bende bir sitemde bu .httacces yapısını çalıştıramadım bilmediğim için çok yırtmıştım kendimi ama windows sunucularda .htaccess'in çalışmadıgını öğrenince pes ettim ugraşmaktan :) sanirim sizinde sunucunuz windows 2003 olabilir.Eğer öyleyse boşuna tırmalamaya gerek yok :)
 
0
Onaylı Üye
Üye
Katılım
25 Haziran 2005
Mesajlar
4,856
Tepki puanı
6
Konum
Bursa
.htaccess windows hostlarda calışmaz. sadece linux sunucularda calışır.
 
Geri
Üst