İyinet'e Hoşgeldiniz!

Türkiye'nin En Eski Webmaster Forum'una Hemen Kayıt Olun!

Kayıt Ol!

MySql Access Databaselerde Türkce Karakter Problemi

Uurz

0
İyinet Üyesi
Katılım
20 Mart 2005
Mesajlar
668
Reaction score
0
Konum
W
Mrblar..
bi windows server var mysql ve access database lerden veri okurken türkce karakterleri ? isareti seklinde okuyor.. ama access database i access ile acip baktigimda karakterler normal. ne yapilabilir ? mysql de de access da da bu problem var..

Windows 2003 web edition server..

Herkese pesinen tesekkurler..
 

iyinet

Root
Admin
Hosting Firması
Katılım
2 Eylül 2002
Mesajlar
5,028
Reaction score
62
Konum
Sakarya
Bu verileri neyle okuyorsun, web server uzerinden bir programla mi yoksa makinadaki bir client ile mi?
Bazen veriyi okuyan client in karakter seti veriyi ekrana dogru basmaz.
iso_1 ve latin5 karakter setlerini denemeni tavsiye ederim.
 

Uurz

0
İyinet Üyesi
Katılım
20 Mart 2005
Mesajlar
668
Reaction score
0
Konum
W
hizli cevabin icin tesekkurler admin..
bi makineden bu yeni makineye siteleri tasiorum. dosyalariyla oynamiorum. IIS 6 var. ama scriptler yeni makinede bu karakterleri okuyamiorum. vbulletin mesela.

bu latin5 ayarlarini yada iso_1 ayari nerden yapilior.?

tesekkurler..
 

iyinet

Root
Admin
Hosting Firması
Katılım
2 Eylül 2002
Mesajlar
5,028
Reaction score
62
Konum
Sakarya
php.ini icinde:

PHP:
default_charset = "UTF-8"

satirini buna cevir:

PHP:
default_charset = "iso-8859-9"
 

Uurz

0
İyinet Üyesi
Katılım
20 Mart 2005
Mesajlar
668
Reaction score
0
Konum
W
olmadı ?
Php içinmiydi bu ?
asp script ve access database li bi deneme yaptım olmadı..

Napabiliriz arkada$lar ba$ka ?
 

Uurz

0
İyinet Üyesi
Katılım
20 Mart 2005
Mesajlar
668
Reaction score
0
Konum
W
hala cozemedim olayi ya yok mu yardim edebilecek bi arkadas :(
 

okan23

0
İyinet Üyesi
Katılım
29 Eylül 2005
Mesajlar
499
Reaction score
0
mssql konusunda bir şey diyemiyeceğimde mysql versiyonu 4.1 mi
 

hakanyal

0
İyinet Üyesi
Katılım
20 Şubat 2005
Mesajlar
302
Reaction score
0
dostum bu olayın en kolay çözümü accesi açacaksın ş,ı,ğ, doğru çıkmıyorsa bunun yerine doğru olarak çıkan karakterleri replace etmen. dbye site üzerinden eklediğin kayıtlarda o özel karakter kullanılacaktır.
 

zokkie

0
İyinet Üyesi
Onaylı Üye
Katılım
8 Şubat 2003
Mesajlar
1,465
Reaction score
0
phpbb ve mysql için karakter sorun giderici:

db bağlantısından hemen sonra :

$db = new sql_db($dbhost, $dbuser, $dbpasswd, $dbname, false);
mysql_query("set character_set_results = 'latin1';");
mysql_query("set collation_connection ='LATIN1_GENERAL_CI';");
mysql_query("set names 'latin1';");
if(!$db->db_connect_id)
 

uyuz

0
İyinet Üyesi
Katılım
31 Aralık 2003
Mesajlar
2,515
Reaction score
0
zokkie' Alıntı:
phpbb ve mysql için karakter sorun giderici:

db bağlantısından hemen sonra :

$db = new sql_db($dbhost, $dbuser, $dbpasswd, $dbname, false);
mysql_query("set character_set_results = 'latin1';");
mysql_query("set collation_connection ='LATIN1_GENERAL_CI';");
mysql_query("set names 'latin1';");
if(!$db->db_connect_id)
bende de aynı sorun vardı ama bu dediğini yapınca düzelmedi...
 

Uurz

0
İyinet Üyesi
Katılım
20 Mart 2005
Mesajlar
668
Reaction score
0
Konum
W
:( malesef
Simdi durumumu daha genis aciklayim belki daha iyi yardimci olabilirsiniz..
Yeni server kiraladim ve siteleri yeni makineye tasiyorum. Eski makine Windows hersey normal calisior makinede versionu mysql 4.0.20 idi.. Yeni makinede windows. Yeni makinedeki version MySQL 4.1.12 ..
Simdi her zaman yaptigim gibi eski makinede export ediyorum sql i alip yeni makinede sql sorgulamasi ile yukluyorum. Amma ö ü haric türkce karakterler cikmiyor.
Mysql database lerde de cikmiyor access database lerde de cikmiyor..
Access database ler daha önemli simdi benim icin.

Remote ile makineyi kontrol edebilirim. Neler deneyebilirim arkadaslar ?

Herkese cok cok tesekkürler...
 

Angelo

0
İyinet Üyesi
Katılım
13 Aralık 2004
Mesajlar
9,603
Reaction score
111
Konum
AZ
Windows'da nasil oldugunu bilmedigim icin, Phpmyadmin araciligiyla MySQL Setup'ina girip Collation ayarlarini duzenlemen lazim, latin5 yaptiginda Turkceleri gosteriyor olmasi lazim
 

uyuz

0
İyinet Üyesi
Katılım
31 Aralık 2003
Mesajlar
2,515
Reaction score
0
aynı sorun bende de var, phpmyadminden mysql ayarlarını da yaptım türkçe olacak şekilde, .htaccesslerden de ayarladım ama nafile :(
 

Uurz

0
İyinet Üyesi
Katılım
20 Mart 2005
Mesajlar
668
Reaction score
0
Konum
W
collation ayarida yaptim yemedi
access icin ne yapabiliriz ?
 

uyuz

0
İyinet Üyesi
Katılım
31 Aralık 2003
Mesajlar
2,515
Reaction score
0
hehehehehey süper hallettim kendi sorunumu :D

3-5 mesaj üstteki zokkie arkadaşın verdiği koddaki latin1 leri latin5 yapıp dene bir de uğur arkadaşım, bende oldu
 

Uurz

0
İyinet Üyesi
Katılım
20 Mart 2005
Mesajlar
668
Reaction score
0
Konum
W
hayir phpnuke de kullanmiorum vbulletin var woredpress var hepsinde türkce karakter problemi oluyor..

access db lerde de oluyor.. :(
 

RemiX

0
İyinet Üyesi
Katılım
25 Mart 2005
Mesajlar
214
Reaction score
0
win de bendede oluyor? Adminden haf ekleyince bazı yerlerinde Ş İ yi gosteriyor bazı yerlerinde gostermiyor admin onemli degide asıl index ve ara sayfalarda gostermiyor. Ama manuel sayfaya eklenince gozukuyor db si access , access in icinden düzeltme de yaptım access de ş İ gozukurken gene sitede gozukmuyor :( Tam olarak hangi ayari yapmam gerek ve nereden yapabilirim plesk kullanıyorum :S
 

Türkiye’nin ilk webmaster forum sitesi iyinet.com'da forum üyeleri tarafından yapılan tüm paylaşımlardan; Türk Ceza Kanunu’nun 20. Maddesinin, 5651 Sayılı Kanununun 4. maddesinin 2. fıkrasına göre, paylaşım yapan üyeler sorumludur.

Backlink ve Tanıtım Yazısı için iletişime geçmek için Skype Adresimiz: .cid.1580508955483fe5

Üst