Türkiye'nin En Eski Webmaster Forumu İyinet'e Hoşgeldiniz!

php sürüm yükseltmede sorun ! YARDIM

yagmayok

1
Onaylı Üye
Üye
Katılım
25 Ocak 2005
Mesajlar
7,131
Açılan Konu
304
Tepki puanı
86
Merhaba arkadaşlar;

Bu sıralar benden bu tarz sorunlar ilgili çok konu açılacak. Çünkü artık sunucu olayına geçmiş bulunmaktayım. Bilgim sıfır. Çok yazı okumaya çalışıyorum. Ama aklım çok karıştı...

neyse konuya geçelim...

PHP sürüm yükseltme işlemi yapim dedim. Yaptım. Yükseldi ama

php -v dediğimde

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/dbase.so' - /usr/lib/php4/dbase.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/dom.so' - /usr/lib/php4/dom.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/gd.so' - /usr/lib/php4/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/imap.so' - /usr/lib/php4/imap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/json.so' - /usr/lib/php4/json.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/mbstring.so' - /usr/lib/php4/mbstring.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/mysql.so' - /usr/lib/php4/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/mysqli.so' - /usr/lib/php4/mysqli.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/pdo.so' - /usr/lib/php4/pdo.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/pdo_mysql.so' - /usr/lib/php4/pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/pdo_sqlite.so' - /usr/lib/php4/pdo_sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/xmlreader.so' - /usr/lib/php4/xmlreader.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/xmlwriter.so' - /usr/lib/php4/xmlwriter.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/xsl.so' - /usr/lib/php4/xsl.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php4/zip.so' - /usr/lib/php4/zip.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.2.5 (cli) (built: Jan 19 2008 10:08:24)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies

Hataları ile karşılaştım. Ne yapmam gerekli...
 

kutver

0
Onaylı Üye
Üye
Katılım
30 Haziran 2005
Mesajlar
148
Açılan Konu
17
Tepki puanı
0
anladığım kadarıyla php.ini dosyasını değiştirmemişsin ondan kaynaklı görünüyor.
 

yagmayok

1
Onaylı Üye
Üye
Katılım
25 Ocak 2005
Mesajlar
7,131
Açılan Konu
304
Tepki puanı
86
Valla ben bişi yapmadım :D

wget -q -O - http://www.atomicorp.com/installers/atomic.sh |sh
yum install php-xml php-pdo
yum install php-pear
mv /etc/php.ini.rpmnew /etc/php.ini

aynen bu yönregelri uyguladım. Onun dışında bir işlem de bulunmadım...

peki ne yapmam lazım


Edit:

Şimdi baktımda etc içinde php.ini ve php.ini.rpmnew dosyaları duruyor...ve içlerinde yukarıdaki hatalarda yer alan dbase.so vs... ile ilgili bir yazı bulunmamakta...

Aynı zamanda usr/lib/php4 ün içide boş
 

kutver

0
Onaylı Üye
Üye
Katılım
30 Haziran 2005
Mesajlar
148
Açılan Konu
17
Tepki puanı
0
php.ini ve php.ini.rpmnew

bunla bunun yerini değiştirmen gerekli :)
 

yagmayok

1
Onaylı Üye
Üye
Katılım
25 Ocak 2005
Mesajlar
7,131
Açılan Konu
304
Tepki puanı
86
kutver teşekkür ederim...

Sorun çözüldü galiba...

kutever arkadaşımızı dediğni yaptım ve

"php.ini" ile "php.ini.rpmnew" içeriğini birbirleriyle değiştirdim.

ve php -v dediğimde

PHP 5.2.5 (cli) (built: Jan 19 2008 10:08:24)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies

Çıkıyor...

teşekkür ederim...
 

kutver

0
Onaylı Üye
Üye
Katılım
30 Haziran 2005
Mesajlar
148
Açılan Konu
17
Tepki puanı
0
sevindim kolay gelsin
 
Üst