İyinet'e Hoşgeldiniz!

Türkiye'nin En Eski Webmaster Forum'una Hemen Kayıt Olun!

Kayıt Ol!

Serverde Türkce Karakter Sorunu

ZiRVeDeKiLeR

0
İyinet Üyesi
Katılım
9 Şubat 2006
Mesajlar
516
Reaction score
0
serverim türkce karakterleri desteklemiyor, meta taglarla alakasi yok sanirim cünki olmai gerekn taglarin hepsini koydum.

Konu hakkinda yardimlarinizi bekliyorum.


Selamlar.
 

nokie

0
İyinet Üyesi
Katılım
23 Mart 2005
Mesajlar
1,597
Reaction score
8
Konum
İzmir
mysql'denmi alıyorsun verileri? version 4.1.x mi?

direk html ise, veriler farklı karakter setleriyle depolandığından sen değiştirince onlarda bozuk görünür, UTF-8 yapıp olayı çözebilirsin.
 

iyinet

Root
Admin
Hosting Firması
Katılım
2 Eylül 2002
Mesajlar
5,028
Reaction score
62
Konum
Sakarya
PHP kullaniyorsan php.ini icine
default_charset=iso-8859-9 (tam emin degilim buna benzer bir parametre de olabilir)
yada php sayfasinin en basina
ini_set("default_charset","iso-8859-9");
 

zbahadir

0
İyinet Üyesi
Katılım
19 Mart 2006
Mesajlar
2,416
Reaction score
0
Konum
Trabzon
apache httpd.conf içerisinde DefaultLanguage diye bir satır olacak onu şu şekilde yapmanızda fayda var;

DefaultLanguage tr
 

ZiRVeDeKiLeR

0
İyinet Üyesi
Katılım
9 Şubat 2006
Mesajlar
516
Reaction score
0
server bilgim yok denecek kadar az root komutlarini filan bilmiyorum sadece tarif üzerine birseyler yapmak geliyor elimden.

@iyinet
Kullandigim forum sistemine ait dil paketinde dedigin satir geciyor ve forumda türkce karakterlerde sorun yok.

Ancak ayni kodlari html de meta taglar arasina yazmama ragmen bir sonuc alamiyorum. Kullandigim meta taglar;

<meta http-equiv="Content-Language" content="tr">
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-9">
<meta http-equiv="Content-Type" content="text/html; charset=windows-1254">


nokie yada zbahadir arkadaslarin söyledigi yöntemleri denemedim ama nasil yapabilecegim konusunda bir fikrim yok :(
 

nokie

0
İyinet Üyesi
Katılım
23 Mart 2005
Mesajlar
1,597
Reaction score
8
Konum
İzmir
nokie yada zbahadir arkadaslarin söyledigi yöntemleri denemedim ama nasil yapabilecegim konusunda bir fikrim yok

ISO-8859-9 ve windows-1254 yazan metaları kaldırıp, sadece;

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

yazıp deneyebilirmisin? server ayarları latin1 ve latin5 dışında bir ayar olmadığı sürece türkçe karakter sorunu olmaz.

bu arada kullandığın forum yazılımı nedir?
 

iyinet

Root
Admin
Hosting Firması
Katılım
2 Eylül 2002
Mesajlar
5,028
Reaction score
62
Konum
Sakarya
HTML metininde problem olabilir, gormek lazim...
 

nokie

0
İyinet Üyesi
Katılım
23 Mart 2005
Mesajlar
1,597
Reaction score
8
Konum
İzmir
buyuk ihtimal oyle gibi gozukuyor, dil dosyasinda turkce karakterler de iceren bir kac satir pasteleyebilirmisin?

ayrica dil dosyasi veri tabani uzerinden calisiyorsa, dosyayi yuklerken veri tabanina karakterler bozuk olarak giriliyor olabilir.
 

Türkiye’nin ilk webmaster forum sitesi iyinet.com'da forum üyeleri tarafından yapılan tüm paylaşımlardan; Türk Ceza Kanunu’nun 20. Maddesinin, 5651 Sayılı Kanununun 4. maddesinin 2. fıkrasına göre, paylaşım yapan üyeler sorumludur.

Backlink ve Tanıtım Yazısı için iletişime geçmek için Skype Adresimiz: .cid.1580508955483fe5

Üst